当前位置:首页>弱电技术>网络通信>海康威视网管交换机VLAN划分配置教程

海康威视网管交换机VLAN划分配置教程

交换机划分VLAN的作用

VLAN(Virtual LAN),即虚拟局域网。VLAN 的作用简单来说就是隔离广播域。未进行 VLAN划分前,局域网内所有的设备都处于同一广播域,因此一台计算机发出广播帧,局域网中所有的计算机都能够接受到,使局域网中有限的网络资源被无用的广播信息所占用。

利用 VLAN隔离广播域之后,每一个 VLAN 都是一个广播域,广播帧只能在同一个广播域内传播,这样可以有效的限制广播信息占用带宽资源。

例如:网络环境中有192.168.10.254/24,192.168.20.254/24,192.168.30.254/24,192.168.40.254/24 四个网段,要求这四个网段互通。
网络架构图如下:

海康威视网管交换机VLAN划分教程

核心交换机(core)

1、创建 4 个 vlan,并且分别添加网关地址

2、连接入交换机的级联口 GE0/1 和 GE0/2 配置成 trunk 口,放通需要放通的网段(可以根据需要放通,也可以直接放通所有 vlan);GE0/3 配置成 access 口,放通需要的 vlan(vlan40)。

接入交换机(sw1,sw2)

SW1:创建 vlan10、vlan20;级联口(GE0/1)设为 trunk 口,放通 vlan10,vlan20(也可放通全部 vlan);接设备的端口(GE0/2,GE0/3)设为 access 口,放通需要的 vlan。

SW2:创建 vlan30、vlan40;级联口(GE0/1)设为 trunk 口,放通 vlan30,vlan40(也可放通全部 vlan);接设备的端口(GE0/2,GE0/3)设为 access 口,放通需要的 vlan。

SW3:所有端口配置成 access 口(放通 vlan40)。或者都不配置(默认 vlan1)。

接入设备

设备网关地址要设为交换机里写入的网关地址,不可漏写或写错。

配置步骤:

1、使用交换机出厂自带的console 线

  • 一端接口是1 个 RJ45,用于连接交换机的console 端口(网口样式)
  • 一端接口是 1 个 DB-9(孔)插头,用于连接电脑的COM口(串口)

注:海康威视网管交换机存在两种系列一种是-H 系列,该系列 console 线 Rj45 头是塑料的;另一种是非-H 系列的,该系列的 console 线 Rj45 头有金属包被,由于两种线序不同无法替代使用,请注意区分。

2、终端连接参数如下:

  • 波特率:9600
  • 数据位:8
  • 停止位:1
  • 奇偶校验:无
  • 流量控制:无

3、通过windows超级终端登录交换机,使用system-view命令进入系统视图,开始配置

<HIK>system-view

System View:return to User View with ctrl+z

4、创建VLAN10并配置相关参数

<HIK> vlan 10

注:vlan 号为自定义号码,从 1-4094,交换机默认所有端口都是 vlan1

<HIK-vlan10>description yewu
注:添加描述(描述为可选项,为了方便后续查看 vlan 所代表的意义)

<HIK-vlan10>interface vlan 10

注:进入 vlan10 的接口视图下配置 vlan10

<HIK-vlan-interface10>ip address 192.168.10.1 255.255.255.0

注:添加 vlan10 的网关地址,此网关地址即为写在设备上的网关地址。此命令只有在三层交换机上添加网关的时候才需要写,如果网关不在此交换机上则只需要划 vlan 不需要写网关。

只有 三 层交换机才能写网关地址,实现不同网段互通的功能,二层交换机不能作为核心交换机,不能实现跨网段三层转发的功能,只能实现 vlan 隔离的功能。

<HIK-vlan-interface10>quit

注:退出 vlan 的配置视图,回到系统视图

接下来,可以使用命令display interface brief查看各个端口的状态,如下图

海康威视网管交换机VLAN划分教程

VLAN(以及网关)创建完成后,下一步就是将交换机的端口划入对应 vlan。交换机端口类型主要有两种,access 口和 trunk 口。简单来说,access 口只允许一个 vlan 通过,也就是说access 口只允许其放通的 vlan 对应的网段通过,一般用于接设备;trunk 口可以允许多个 vlan通过,可以透传多个网段,一般用于交换机与交换机之间互连,不直接接设备。

access 口配置方法

<HIK>interface e1/0/1

注:进入 e1/0/1 的端口视图(E 代表百兆,G 代表千兆,X 代表万兆)

<HIK-Ethernet1/0/1] port link-type access

<HIK-Ethernet1/0/1]port access vlan 10

注:配置 E1/0/1 端口,端口类型设为 access,并将此端口划入 vlan10

<HIK-Ethernet1/0/1]quit

注:退出端口视图

<HIK>interface range e1/0/2 to e1/0/10

<HIK-if-range>port access valn 10

注:批量配置端口,将 2到10 端口都划入 vlan10

<HIK-if-range>quit

注:退出视图

至此VLAN10创建完成,接下来创建VLAN20,创建方法同VLAN10

配置过程:创建 vlan—配置 vlan–添加网关(可选)–配置端口—将端口划入 vlan

trunk配置方法

<HIK>interface e1/0/1

<HIK-Ethernet1/0/1]port link-type trunk

<HIK-Ethernet1/0/1]port trunk permit vlan 10 20 30

注:进入 E1/0/1 的端口视图下进行配置,将端口类型设置成 trunk,trunk 口放通 vlan10、vlan20、vlan30.(这样三个 vlan 所对应的网段都能从这个端口透传过去)

<HIK-Ethernet1/0/1]undo port trunk permit vlan 1

注:一般配置 trunk 口的时候会手动禁止 vlan1 通过,因为设备端口默认是 vlan1,这样 vlan1的数据会被默认放通,由于一般不配置 vlan1,因此我们会手动禁止 vlan1 通过。

<HIK-Ethernet1/0/1]quit

注:退出视图

配置过程:跟配置 access 口的思路基本一致,同样是创建 vlan—配置 vlan–添加网关(可选)–配置端口,不同的是 trunk 口后面是配置端口—将端口类型设备为 trunk—trunk 放通vlanxx(xx表示vlan编号)

5、保存配置

<HIK>save force

海康威视网管交换机VLAN划分教程

本文由 @孔明 发布于弱电智能网 。

题图来自Unsplash,基于CC0协议

内容观点仅代表作者本人,弱电智能网平台仅提供信息存储空间服务。

如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。

添加微信ydian188免费入群,记得备注“弱电智能网”。

给TA打赏
共{{data.count}}人
人已打赏
网络通信

华为交换机打开光口命令

2022-6-17 17:17:31

网络通信

华为交换机ACL的配置规则及实例

2022-6-17 19:03:10

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
搜索